SOLVED: uses-sdk:minSdkVersion 16 cannot be smaller than version 21 declared in library
 


uses-sdk:minSdkVersion 16 cannot be smaller than version 21 declared in library [Camera]

This simply means that one of your external libraries has specified a different minSdkVersion than the one you specified for your project. In this case, the camera library has specified a different minSdkVersion. It is therefore not enough to specify minSdkVersion in your AndroidManifest.xml file. Do a search on the whole project folder for files containing the text minSdkVersion to find the exact file. Once you find the file just change the minSdkVersion to the version you need in this case 21

 
 
 
 
 
COPYRIGHT © 2017 java-samples.com. ALL RIGHTS RESERVED.